Important news from Waves for MAC users

Waves has informed us on their website that users who run their plugins on the Mac OSX platform, do not upgrade to MAC OS 10.4.9!

They state that: “Mac OS 10.4.9 is not supported and causes Waves plug-ins to malfunction.
Do not install Mac OS 10.4.9 until further notice.”

A short, but very clear message!


Post Your Thoughts