Native Instruments products fully compatible with TIGER

Nearly all Native Instruments products are fully compatible with the new Apple Mac OS 10.4 operating system without the need to install any NI update. If you would like to upgrade to Mac OS 10.4, we recommend choosing the installation type “Upgrade Mac OS X”, which will not require new authorization of your Native Instruments products.

Important notes:

– TRAKTOR DJ Studio 2.6 and TRAKTOR FS 2 require an NI update, which is now available in the NI Updates Manager.

– Finalscratch 1 and 1.5 were designed for use with Mac OS X Jaguar (10.2.8) and do not run on Mac OS X Tiger (10.4.x)!

– NI KOMPLETE 2: If you intend to install NI KOMPLETE 2 on Tiger, you first need to install a small update in order to authorize NI KOMPLETE 2. The patch is not needed if you have an existing NI KOMPLETE 2 installation and choose “Upgrade Mac OS X” when upgrading to OS 10.4.

In addition NI recommends:

Before you upgrade to Tiger please make sure that you collect Tiger upgrade information from the manufacturers of the hardware/software you use in combination with your Mac OS system and download possibly available driver (compatibility) updates for your audio/midi devices etc.

For more information please visit and read the Tiger Installation Guide.

Post Your Thoughts