KORG Legacy Collection 64-bit Compatibility

Korg are pleased to announce that the KORG Legacy Collection series is now available in 64-bit! KORG’s Legacy Collection series, made up of legendary KORG synthesizers including MS-20, Polysix, Mono/Poly, WAVESTATION and M1, as well as MDE-X effects processor and LegacyCell will now work on the latest 64-bit DAWs.

Legacy Collection

Since 2004, Korg’s Legacy Collection plugins have helped thousands of users to incorporate the unique sounds of some of Korg’s most coveted synths into their productions and performances. Korg’s proprietary CMT (Component Modeling Technology) method literally models each component of the signal chain within the original synth for unparalleled realism. Trust us, we’ve done the comparisons.

 This update is available to registered users as a free download. Log into KORG USER NET via the right column, and click [Download for registered users]. Note: For KLC-1 v1.0-1.1 owners, you must have previously purchased and registered “v1.2 Upgrade” for access to this update.

Details of the update

Note that minimum system requirements have been changed to add support for 64-bit functionality. Please do not update your software if you do not meet these minimum requirements.


  • Native 64-bit Audio Units and VST plug-ins are now supported.
  • Mac OS X 10.8 Mountain Lion is now supported.
  • This update requires Mac OS X 10.6 (or later). Power PC and Mac OS X 10.5 (or earlier) are no longer supported. For additional details on the system requirements, please visit the product page.


  • Native 64-bit VST plug-in is now supported on Windows 7 or later.
  • Windows 8 is now supported.
  • System requirements have been changed. For full details on the system requirements, please visit the product page.


Post Your Thoughts